subversion 1.7.8 linux下的安装笔记

因为eclipse换成了4.2.1,里面自带的svn就更新到了1.8.0,在命令终端中用1.6版本的svn就不能使用了,就只能去安装1.7+的svn。

安装subversion-1.7.8 需要依赖以下包:
SQLite-3.7.15.1, Apr-Util-1.5.1 and neon-0.29.6 或者 serf.

对于这些最好不要尝试自己去编译,直接用下面命令即可,各个包又会依赖于其他包,累人!(Apr-Util依赖于Apr,neon依赖于libxml2-2.9.0 或者 expat-2.1.0)

sudo aptitude install libneon27
sudo aptitude install libsqlite3-0
sudo aptitude install libapr1
sudo aptitude install libaprutil1-dev

wget http://mirrors.tuna.tsinghua.edu.cn/apache/subversion/subversion-1.7.8.tar.gz
tar -zxvf subversion-1.7.8.tar.gz
./configure –disable-static –without-berkeley-db
make
sudo make install

错误:
make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1
遇见这个问题,原本想自己编译所有的依赖包,后来想想算了。
解决:
–with-apr 和 –with-apr-util要指源码包里面,不能指安装好的地方的

错误:
/usr/local/lib/libz.a: could not read symbols:

解决办法:
cd zlib-1.2.3
vi Makefile
找到 CFLAGS=-O3 -DUSE_MMAP — > CFLAGS=-O3 -DUSE_MMAP -fPIC

make && make install
重新编译下zlib即可!

作者: inter12

在这苦短的人生中,追求点自己的简单快乐

发表评论

电子邮件地址不会被公开。 必填项已用*标注